Come correggere e riparare un IMEI non valido sui dispositivi MediaTek

141

Uno dei principali problemi che hanno gli utenti dei telefoni MediaTek, è come risolvere un IMEI non valido sui dispositivi MediaTek con processori MTK MT6516 / MediaTek MT6589 MT6592 MT6595 MT6572 MT6589T MT6582 MT6577.

mobileuncleQuesta guida vi mostrerà un metodo (ne esistono altri) per riparare IMEI non valido sui dispositivi MediaTek / MTK. Per far funzionare questo metodo si richiede l’installazione di una semplice applicazione, pochi tocchi e scrivere una riga di comando.

Prima di iniziare, la prima cosa da fare è scaricare e installare dal Play Store Mobileuncle MTK tools o in formato APK DA QUI e seguire questi passaggi:

mtk-imei-7

  1. Dopo aver scaricato ed installato l’app, aprirla e selezionare Engineer Mode
  2. Selezionare Engineer Mode MTK
  3. Selezionare CDS Information della scheda Connectivity
  4. Selezionare Radio Information
  5. Selezionare la scheda SIM su cui si desidera cambiare l’IMEI
  6. Alla linea AT+ per la SIM 1, immettere: AT+EGMR=1,7,IL-PRIMO NUMERO IMEI. Per la SIM 2, immettere: AT+EGMR=1,10,IL-SECONDO NUMERO IMEI. Naturalmente, dove sono le parole “……… NUMERO IMEI” si deve inserire il numero IMEI di ogni scheda SIM.

mtk-change-imei-2Al #6 è necessario immettere il codice IMEI prelevato dalla scatola del telefono o nelle informazioni sotto la batteria. In alcuni casi, è possibile che un telefono dual SIM abbia lo stesso codice IMEI per entrambi gli slot SIM. Nel caso in cui il gestore non consente questo, o se avete qualche altra ragione è necessario modificare lo stock IMEI. In questo caso potrebbe essere necessario generare / calcolare / trovare un nuovo IMEI con il checksum corretto / check digit sul tuo MTK6589T, MTK6589 o sui telefoni MTK6592 MTK6595 MTK6572 MTK6582 MTK6577 MTK6516.

Con questa procedura per riparare IMEI non valido sui dispositivi MediaTek dovrebbe risolvere il problema, ma ci sono anche situazioni in cui cambiando l’IMEI non funziona, indipendentemente dal metodo utilizzato. In tal caso, potrebbe essere necessario ripristinare la NVRAM da un backup precedente o da un backup di un amico.

141 COMMENTI

  1. Buongiorno Simone io ho acquistato da poco un S7 Edge clone con sistema MT6580. Il telefono ha un problema; non riceve bene il segnale. Il venditore mi ha detto di modificare il codice Imei. Cosa che ho già fatto ma è rimasto il problema, vorrei gentilmente sapere da lei cosa posso fare per risolvere questo problema. In attesa di una sua risposta. Distinti saluti.

    • Ciao Renato, quello da te descritto è un problema molto vasto e difficilmente risolvibile con i pochi dati a disposizione. Quello che consiglierei di fare è inizialmente un ripristino alle impostazioni di fabbrica. Successivamente proverei con diverse SIM di diversi operatori per capire se il problema è il telefono oppure l’operatore. Anche spostandoti in posti diversi della città il problema non cambia?

  2. ciao simone io ho un oukitel c4 faccio l’istallazione del programma ma nella voce engineer mode mi esce solo android come devo fare???
    grazie

  3. Ciao Simone.

    Posseggo da 2 anni lo smartphone Zopo Zp980 Plus dual sim -Processore Mediatek Octa-Core MT6592 a 1.7 GHz con
    Android versione 4.2.2 Jelly Bean.
    Dopo un ripristino di fabbrica effettuato con flash tool rimettendo il firmware originale ho provato in tutti i modi anche tramite programmi ma il codice Imei non rimane permanente e dopo qualche riavvio o alcuni minuti scompare.
    Comunque anche quando è visibile è impossibile effettuare telefonate, sms e connessione dati con qualunque sim. Il wi-fi funziona. Non ho copia di partizione Nvram. Il codice Imei anche se originale ho controllato sul sito http://www.numberingplans.com/… ed ho avuto conferma che è tutto a posto. Vorrei sapere se c’è una soluzione alternativa al mio problema che mi affligge in quanto è un peccato avere un telefono perfettamente funzionante ma non poterlo utilizzare. Grazie

    • Ciao, solitamente il metodo proposto in questa guida risolve il problema permanentemente. Hai provato a flashare nuovamente il firmware e poi correggere nuovamente l’IMEI?

      • Ciao grazie per avermi risposto. Si l’ho fatto tanto di quelle volte che non si contano, così come tanti i modi per rimettere il codice Imei, anzi poco fa ho provato ad inserire quello di un altro mio vecchio telefono che non uso più ma il risultato è sempre lo stesso, che dopo il secondo riavvio il codice Imei non appare più e riporta imei non valido 🙁

        • Sinceramente è un problema molto strano. Non saprei cosa consigliarti se non i metodi che certamente hai già testato. A questo punto, se possibile, cerca di rivolgerti all’assistenza.

      • Ciao simone,sinceramente l ultima possibilità sarebbe il programma che ho visto usare e con successo Z3 TOOL PRO v24.3 per craccare il cell !però tutti i siti che ho visitato per scaricare il programma sono pieni di virus e inoltre non mi fanno scaricare niente…!!!se riesce a farmi sapere come fare o deve andare saresti un grande..!?appena hai tempo attendo notizie.!grazie e buon anno..

        • Ciao, ne ero venuto a conoscenza anche io. Ma penso sia più uno specchietto per le allodole messo lì per guadagnare con la pubblicità. Non si riesce a scaricarlo in nessun modo.

  4. salve ho un telefonino clone s7 edge con processore MT6580 quando vado in engineer mode non mi trova engineer mode mtk ma solo android

  5. Ragazzi una domanda. io ho uno z4 clone dual sim.
    Emei perduti dopo formattazione e aggiornamento.
    Ne ho presi due da un samsung vecchio e rotto dual sim.

    inseriti grazie alla vostra procedura tutto funziona eccetto la rete internet.
    sul cell mi compare la scritta G, e zero connessione dati.
    sapreste aiutarmi?

    • Ciao, hai verificato se nelle impostazioni i dati cellulare sono attivi e se sono prese nei tutte le configurazioni del tuo operatore?

  6. Ciao una domanda URGENTE quando dici : 6.Alla linea AT+ per la SIM 1, immettere: AT+EGMR=1,7,IL-PRIMO NUMERO IMEI , quindi devo scrivere AT+EGMR=1,7,E IL MIO CODICE IMEI TUTTO QUESTO ATTACCATO SENZA SPAZI? PERCHE; MI DICE IL COMANDO NON E’ PERMESSO IN USERBUILD . COME FACCIO? HO UN MEIZU M2NOTE DUAL SIM.

  7. Salve Simone, grazie per il post, io ho un mediacom g400 ma la procedura non funziona, sarà perché devo abilitare i permessi di root? Grazie in anticipo per la risposta

  8. Ciao io ho comprato un clone di iPhone 6s plus e non mi viene più il logo di accensione dell iphone ma mi viene quello della Mediatek come faccio mi auutereste

  9. Ciao..Io ho un phone pad duo appena ripreso dal centro assistenza. Appena l’ho riacceso, risulta l’IMEI non valido..e non so cosa fare
    Potresti aiutarmi? Grazie in anticipo

    • Ciao, dato che il problema si è presentato dopo aver ritirato lo smartphone dall’assistenza, ti consiglio di portarlo nuovamente a loro prima di eseguire qualche procedura che invalidi la garanzia.

  10. Ciao.. Ho un Clone Note 3. Il telefono si connette ad internet (connessione dati) sono con la lettera “e” ed è lentissimo. Non esce la lettera “h”… Ho Tim! Cosa devo fare?

  11. io ho mediatek klone iphone 6 ma quando inserisco la sim non la rileva, sapete dirmi il perchè, come posso fare o da ki posso portarlo? grazie

  12. ho un tablet 3gcn processore mediatek e lo formttato e dice imei non valido e non mi fa usare la sim il programma indicato in questa giuda non è compatibile con la mia versione

    • Ciao, pur installando la ROM stock non risolveresti. L’unica cosa da fare è seguire una procedura, come quella indicata nella guida, per il recupero dell’IMEI.

  13. salve ho un grosso problema con un clone del s5 mt6572, all’accensione legge le sim inserisco il pin, quando si sblocca non ce linea, e sparita l’app telefono, mi fa connettere solo in wifi, ho i permessi di root, e nelle info del cell alla voce imei ce scritto uknow qualcuno puo aiutarmi? ho provato piu volte a ripristinare ma senza nessun risultato, HELP ME

  14. Salve, ho provato con il mio Samsung S4 ma non mi compare “Engineer Mode MTK”… è un problema che ho riscontrato con altre guide e non riesco a risolvere il mio problema. Non capisco il motivo. Puoi aiutarmi? Grazie

  15. Come mai a me non compare la tastiera per scrivere …?…sto provando tutte le procedure possibili ma non riesco a far tornare i 2 Imei…un grazie per l’aiuto

  16. ho provato questa guida ma l’applicazione non mi consente di eseguire il comando: this command is not allowed in UserBuild

  17. ciao ho seguito la guida completamente ho riavviato il cel e ce linea
    premetto che avevo riparato con mobileuncle ma facendo il ripristino di fabbrica era sempre la solita storia rifare il root e reinserire IMEI adesso spero che sia tutto apposto fino a che non smanetto di nuovo al mio smartphon non lo sapro ma vi ringrazio davvero tantissimo siete fantastici il vosto impegnio x aiutare il prossimo non ha parole grazie grazie davvero tanto

  18. ciao a tutti..avrei bisogno d aiuto! ho comprato un htc desire 816 su e bay non facendo caso della provenienza ed stato prodotto negli stati uniti quindi nn mi legge la rete italiana.con questo metodo posso cambiare l imei con successo e facendo si che mi legga la rete italiana? il sistema operativo e 4.4 kitkat

    • Ciao, questo metodo funziona solo su smartphone con processore mediatek. Se avremo informazioni in merito al tuo problema pubblicheremo una guida.

  19. anche io ho flashato una rom e ho perso l’imei, ora con il tuo metodo mi dice

    this command is not allowed in UserBuild e non so come fare

    • Ciao, hai inserito correttamente i comandi? Controlla gli spazi. Anche un piccolo errore ed il codice non viene accettato.

          • no il prolema era quello, altrimenti non sarei stata qui a cercare soluzioni.Comunque sono riuscita a risolvere grazie all’aiuto di Antonio che aveva scritto qui. Non smetterò mai di ringraziarlo

  20. Ciao a tutti ieri ho avuto la bella pensata di afgiornare il mio n9800 star kingelon a android 4.4.2 ho flashato una rom scaricaya da needrom ma una Volta riavviato I’ll cell not n aveva piu LA rear cam funzionante.poco male ho pensato ci riflashio in altra ROM e torna tutto a posto.invece ora mi ritrovo col cell che non ha piu imei ho provato tutti I metodi ma non son riescito a riscriverlo.credo di aver canncellato una qualche cartella che li continue e quindi ora non sappia piu dove and are a riscriverlo.Avete idee o suggerimenti da provare? Grazie Salvatore

      • era semplicemente un errore che commettevo nel non inserire lo spazio dopo il comando at ora sono riuscito a ripristinarli fermo restando tutti gli altri probl soprattutto cam rear che non f viene nemmeno riconosciuta in fase test

          • si ma non trovo nemmeno il modo di ritornare indietro alla 4 2 2 che tutto sommato funzionava ho tentato con rom prese da needrom ma nessuna mi fa tornare indietro

          • Che opzione scegli da SP Flash Tool dal menù a tendina quando provi a falshare android 4.2.2?

          • in effetti cambia la rom ma nell about phone continua a restare la voce android version 4 4 2

          • in realtà esiste anche una che si chiama star n9800 l ho scaricata ma non c e lo scatter

          • un altro piccolo passo l ho fatto ora è tornato android 4 2 2 la cam ancora non esiste non riesco a fare il root con nessun programma

          • a questo punto convengo con te che non abbia la rom giusta spero di trovarla presto

  21. Ciao a tutti. Si potrebbe avere il backup di una nvram per lenovo A806 MTK6592?? io non l’ho fatto prima di istallare la ROM e ora nemmeno con l’app riesco a modificarlo. Con altre app ci sono andato vicino a ripristinarlo ma mancano comunque i file adatti al mio smartphone.Grazie a tutti, e comunque articolo utilissimo!! Complimenti e grazie!

      • Quando arrivo nella stringa dei comandi e digito E, finisco a scrivere il resto, vado per premere “send at command” e mi esce la scritta: “this command is not allowed in UserBuild” anche se comunque seguendo la procedura entro con Engineer Mode

        • Prova a scrivere lo stesso comando di prima ma con uno spazio tra AT e +. Dovrebbe uscire una cosa del genere:

          AT +EGMR=1,7,”IMEI_num_here”

          fammi sapere se funziona.

          • Proprio perché non cambia niente, esce la stessa scritta. Ho provati sia a inserire soli il primo numero che l’IMEI per intero, non funziona comunque

          • Occhio che hai sbagliato a scrivere il codice. Il codice IMEI deve stare tra i due apici.

          • Ti posso chiedere una cortesia? mi manderesti/posteresti il file apk del tuo SU? Ho spulciato ogni possibile metodo ma il problema sta nell’app Superuser, credo che in questo modo si risolverà quasi certamente al 100%, se mi fai questa cortesia lo sapremo con certezza, grazie!!!

          • E come posso risolvere? Io purtroppo non so i comandi e gli script che potrebbero risolvere il problemaproblema creando un file apposito,è una maledizione!

          • Oggi ho smanettato e finalmente mi esce ”AT comand Sent” vado per riavviarlo e quando si accende di dice sempre ”Invalid IMEI”

          • Una volta installata l’app concedo i permessi di root e avvio l’app. Vado su Engineer mode e su MTK Engineer mode , poi su CDS information sulla sezione Connectivity e su Phone 1, mi si apre la schermata degli screen e digito il comando AT +EGMR=1,7,”83…ecc” clicco su fine e poi su send commando, ora mi esce AT command is mSent. Riavvio e aspetto che si accende. Vado per vedere se l’IMEI è ripristinato e mi esce sempre invalid IMEI.

          • Nono è per questa procedura funziona. L’unica cosa che puoi fare a questo punto è ripristibare la NVRAM. Prova a cercare su Google perché non possiamo pubblicarla sul blog.

          • Risolto. Tramite il prompt dei comandi del mio PC ho generato un nuovo IME (ora non ricordo il comando di preciso)I, l’ho rinominato e nel frattempo avendo scaricato root explorer ho generato dei file zip e TAR e li ho passati sul PC. Non so se sarebbe servito, ma comunque ho cancellato la cartella nvram dalla cartella emulated/system/data e l’ho poi sostituita con la cartella con il nuovo IMEI. Ho riavviato il telefono ed ora è tornato tutto come prima. Grazie per i chiarimenti e per l’aiuto!!

          • Mi dovresti mandare la tua mail perché ti servono un po di cose da installare sul pc ! Se me la scrivi faccio subito

          • Antonio, se ci mandi la procedura tramite email pubblichiamo una guida in modo che tutti quelli che hanno lo stesso problema possono risolverlo celermente.

          • a me dice non è possibile cambiare o usare questo comando in modalita User .serve per caso avere i permessi di rotto per questa procedura ?

  22. AIUTOOOOO,NEL MIO DISPOSITIVI NON TROVO LA CDS INFORMATION NELLA SCHEDA CONNECTIVITY,NE RADIO INFORMATION,COSA POTREI FARE?NON ACCETA NESSUNA SCHEDA……

LASCIA UN COMMENTO:

Please enter your comment!
Please enter your name here