Come correggere e riparare un IMEI non valido sui dispositivi MediaTek

145

Uno dei principali problemi che hanno gli utenti dei telefoni MediaTek, è come risolvere un IMEI non valido sui dispositivi MediaTek con processori MTK MT6516 / MediaTek MT6589 MT6592 MT6595 MT6572 MT6589T MT6582 MT6577.

mobileuncleQuesta guida vi mostrerà un metodo (ne esistono altri) per riparare IMEI non valido sui dispositivi MediaTek / MTK. Per far funzionare questo metodo si richiede l’installazione di una semplice applicazione, pochi tocchi e scrivere una riga di comando.

Prima di iniziare, la prima cosa da fare è scaricare e installare dal Play Store Mobileuncle MTK tools o in formato APK DA QUI e seguire questi passaggi:

mtk-imei-7

  1. Dopo aver scaricato ed installato l’app, aprirla e selezionare Engineer Mode
  2. Selezionare Engineer Mode MTK
  3. Selezionare CDS Information della scheda Connectivity
  4. Selezionare Radio Information
  5. Selezionare la scheda SIM su cui si desidera cambiare l’IMEI
  6. Alla linea AT+ per la SIM 1, immettere: AT+EGMR=1,7,IL-PRIMO NUMERO IMEI. Per la SIM 2, immettere: AT+EGMR=1,10,IL-SECONDO NUMERO IMEI. Naturalmente, dove sono le parole “……… NUMERO IMEI” si deve inserire il numero IMEI di ogni scheda SIM.

mtk-change-imei-2Al #6 è necessario immettere il codice IMEI prelevato dalla scatola del telefono o nelle informazioni sotto la batteria. In alcuni casi, è possibile che un telefono dual SIM abbia lo stesso codice IMEI per entrambi gli slot SIM. Nel caso in cui il gestore non consente questo, o se avete qualche altra ragione è necessario modificare lo stock IMEI. In questo caso potrebbe essere necessario generare / calcolare / trovare un nuovo IMEI con il checksum corretto / check digit sul tuo MTK6589T, MTK6589 o sui telefoni MTK6592 MTK6595 MTK6572 MTK6582 MTK6577 MTK6516.

Con questa procedura per riparare IMEI non valido sui dispositivi MediaTek dovrebbe risolvere il problema, ma ci sono anche situazioni in cui cambiando l’IMEI non funziona, indipendentemente dal metodo utilizzato. In tal caso, potrebbe essere necessario ripristinare la NVRAM da un backup precedente o da un backup di un amico.

  • ROBY

    AIUTOOOOO,NEL MIO DISPOSITIVI NON TROVO LA CDS INFORMATION NELLA SCHEDA CONNECTIVITY,NE RADIO INFORMATION,COSA POTREI FARE?NON ACCETA NESSUNA SCHEDA……

    • guideitech

      Ciao, il tuo è un problema di IMEI oppure di blocco regionale del telefono? Che telefono hai?

      • roby

        Salve e una clone di galaxy s5-mtk g 900 h,la cosa che mi ha fatto dubitare s che il imei sotto la batteria non e lo steso con quello che apare quando digiti#06.grazie

        • guideitech

          Il telefono era nuovo o di seconda mano quando lo hai acquistato?

          • ROBY

            era di seconda mano

          • guideitech

            Prova a chiedere a chi te lo ha venduto se ha già modoficato l’IMEI.

          • ROBY

            penso che e modificato perche il imei sotto la batteria non e stesso di quello che mi apare digitando #06#.grazie del tuo tempo

          • guideitech

            Non capisco qual è il problema che hai riscontrato. Hai scaricato l’app per modificare l’IMEI?

  • Antonio R.

    Ciao a tutti. Si potrebbe avere il backup di una nvram per lenovo A806 MTK6592?? io non l’ho fatto prima di istallare la ROM e ora nemmeno con l’app riesco a modificarlo. Con altre app ci sono andato vicino a ripristinarlo ma mancano comunque i file adatti al mio smartphone.Grazie a tutti, e comunque articolo utilissimo!! Complimenti e grazie!

  • Alta Tensione Salvatore Mannon

    Ciao a tutti ieri ho avuto la bella pensata di afgiornare il mio n9800 star kingelon a android 4.4.2 ho flashato una rom scaricaya da needrom ma una Volta riavviato I’ll cell not n aveva piu LA rear cam funzionante.poco male ho pensato ci riflashio in altra ROM e torna tutto a posto.invece ora mi ritrovo col cell che non ha piu imei ho provato tutti I metodi ma non son riescito a riscriverlo.credo di aver canncellato una qualche cartella che li continue e quindi ora non sappia piu dove and are a riscriverlo.Avete idee o suggerimenti da provare? Grazie Salvatore

    • guideitech

      Ciao, che problemi hai riscontrato con questa guida?

      • Alta Tensione Salvatore Mannon

        era semplicemente un errore che commettevo nel non inserire lo spazio dopo il comando at ora sono riuscito a ripristinarli fermo restando tutti gli altri probl soprattutto cam rear che non f viene nemmeno riconosciuta in fase test

        • guideitech

          Il problema è che tu hai installato una ROM Custom, non è uscito nulla di ufficiale ancora.

          • Alta Tensione Salvatore Mannon

            si ma non trovo nemmeno il modo di ritornare indietro alla 4 2 2 che tutto sommato funzionava ho tentato con rom prese da needrom ma nessuna mi fa tornare indietro

          • guideitech

            Che opzione scegli da SP Flash Tool dal menù a tendina quando provi a falshare android 4.2.2?

          • Alta Tensione Salvatore Mannon

            format all + download

          • Alta Tensione Salvatore Mannon

            in effetti cambia la rom ma nell about phone continua a restare la voce android version 4 4 2

          • Alta Tensione Salvatore Mannon

            e la cam non continua a funzionare come se non esistesse

          • guideitech

            Sicuro di aver scaricato la ROM corretta?

          • Alta Tensione Salvatore Mannon

            STAR N9800 – Update 03/08/2014 questa ho messo

          • Alta Tensione Salvatore Mannon

            in realtà esiste anche una che si chiama star n9800 l ho scaricata ma non c e lo scatter

          • Alta Tensione Salvatore Mannon

            un altro piccolo passo l ho fatto ora è tornato android 4 2 2 la cam ancora non esiste non riesco a fare il root con nessun programma

          • Alta Tensione Salvatore Mannon

            a questo punto convengo con te che non abbia la rom giusta spero di trovarla presto

  • pandakoala

    anche io ho flashato una rom e ho perso l’imei, ora con il tuo metodo mi dice

    this command is not allowed in UserBuild e non so come fare

    • guideitech

      Ciao, hai inserito correttamente i comandi? Controlla gli spazi. Anche un piccolo errore ed il codice non viene accettato.

      • pandakoala

        si anche perchè l’errore non è command not sent ma come se non mi riconoscesse il root

      • pandakoala

        sicura se cambio qualcosa mi dà il not sent, se lascio così mi dà il problema di userbuild

        • guideitech

          Prima di installare la ROM avevi effettuato un backup della NVRAM?

          • pandakoala

            no il prolema era quello, altrimenti non sarei stata qui a cercare soluzioni.Comunque sono riuscita a risolvere grazie all’aiuto di Antonio che aveva scritto qui. Non smetterò mai di ringraziarlo

  • Lopa Massimo

    Perfetto, ho rinserito l’imei al primo tentativo, grazie mille

    • guideitech

      Prego 😉

  • Pigiamina Fanny

    Ciao ho un clone 5s e mi scrive imei non valida come posso fare?

    • guideitech

      Ciao, hai provato a seguire questa guida?

  • Vincenzo Ferraraccio

    ciao a tutti..avrei bisogno d aiuto! ho comprato un htc desire 816 su e bay non facendo caso della provenienza ed stato prodotto negli stati uniti quindi nn mi legge la rete italiana.con questo metodo posso cambiare l imei con successo e facendo si che mi legga la rete italiana? il sistema operativo e 4.4 kitkat

    • guideitech

      Ciao, questo metodo funziona solo su smartphone con processore mediatek. Se avremo informazioni in merito al tuo problema pubblicheremo una guida.

  • Simone

    ciao antonio potresti dirmi come hai risolto per l’imei. Se gentilmente puoi inviarmi la guida su [email protected]

  • Michele Locicero

    ciao a tutti ho provato ma non va

  • Massimiliano Correnti

    ciao ho seguito la guida completamente ho riavviato il cel e ce linea
    premetto che avevo riparato con mobileuncle ma facendo il ripristino di fabbrica era sempre la solita storia rifare il root e reinserire IMEI adesso spero che sia tutto apposto fino a che non smanetto di nuovo al mio smartphon non lo sapro ma vi ringrazio davvero tantissimo siete fantastici il vosto impegnio x aiutare il prossimo non ha parole grazie grazie davvero tanto

    • guideitech

      Prego, il nostro obiettivo è proprio questo!

  • Michele Locicero

    salve ho provato la guida funziona atratti solo con wind ma con la tim non funziona

  • krys

    *#*#789789#*#* Codice per Cloni s5 note 4 note 3 per inserire il logo samsung modificare la room riparare IMEI

    • Miria

      Ho fatto il codice ma dopo l ultimo asterisco si cancella

    • gianfry.63

      non succede niente?????? note 4

      • Ciao questa guida si rivolge ai possessori di dispositivi con processori mediatek. il tuo samsung non ha processore mediatek.

  • Joshua Micheletti

    ho provato questa guida ma l’applicazione non mi consente di eseguire il comando: this command is not allowed in UserBuild

  • Sergio

    Come mai a me non compare la tastiera per scrivere …?…sto provando tutte le procedure possibili ma non riesco a far tornare i 2 Imei…un grazie per l’aiuto

    • guideitech

      Ciao, che smartphone hai?

      • Sergio

        Ti ringrazio ho risolto con una procedura diversa

  • bianca

    Salve io ho un clone del iphone 6 e non ha la rete ho provato questa procedura ma non funziona…che posso fare?

  • Roberto Trasatti

    Salve, ho provato con il mio Samsung S4 ma non mi compare “Engineer Mode MTK”… è un problema che ho riscontrato con altre guide e non riesco a risolvere il mio problema. Non capisco il motivo. Puoi aiutarmi? Grazie

  • guideitech

    Mi sa che non è una cosa legale inserire l’IMEI di un altro telefono.

    • Roberto Trasatti

      ah quindi non si può fare? Grazie mille!

      • Roberto Trasatti

        e non c’è la possibilità di inserire il mio imei manualmente?

        • guideitech

          Esiste un tool però abbastanza costoso e bisogna disporre di un accessorio hardware per portare a termine la procedura. Qual è il problema che hai con il tuo smartphone?

  • tony testa

    salve ho un grosso problema con un clone del s5 mt6572, all’accensione legge le sim inserisco il pin, quando si sblocca non ce linea, e sparita l’app telefono, mi fa connettere solo in wifi, ho i permessi di root, e nelle info del cell alla voce imei ce scritto uknow qualcuno puo aiutarmi? ho provato piu volte a ripristinare ma senza nessun risultato, HELP ME

  • tony testa

    la voce cds imformation a me non ce

  • tony testa

    dove posso trovare una rom stok per mt6572 e come installarla

    • guideitech

      Ciao, pur installando la ROM stock non risolveresti. L’unica cosa da fare è seguire una procedura, come quella indicata nella guida, per il recupero dell’IMEI.

  • xBakekaIncontri

    best tutorial found

  • Riccardo Giaquinto

    ho un tablet 3gcn processore mediatek e lo formttato e dice imei non valido e non mi fa usare la sim il programma indicato in questa giuda non è compatibile con la mia versione

  • andrea

    io ho mediatek klone iphone 6 ma quando inserisco la sim non la rileva, sapete dirmi il perchè, come posso fare o da ki posso portarlo? grazie

  • Vittorio Fotia

    Ciao.. Ho un Clone Note 3. Il telefono si connette ad internet (connessione dati) sono con la lettera “e” ed è lentissimo. Non esce la lettera “h”… Ho Tim! Cosa devo fare?

    • Ciao, hai provato a verificare se nella tua zona è presente il segnale 3G/HSPA di Tim? Puoi farlo direttamente tramite il sito di Tim collegandoti a questo indirizzo ed inserendo il nome della tua Città: https://www.tim.it/verifica-copertura

      • Vittorio Fotia

        Avevo l’S3 originale e funzionava funzionava. Perche con il clone del note 3 no??
        Il giorno 18/gen/2016 19:36, “Disqus” ha scritto:

        • Verificato se nelle impostazioni sia abilitato il 3G? In caso affermativo prova ad avvalerti della garanzia.

  • Gra Cascione

    Ciao..Io ho un phone pad duo appena ripreso dal centro assistenza. Appena l’ho riacceso, risulta l’IMEI non valido..e non so cosa fare
    Potresti aiutarmi? Grazie in anticipo

    • Ciao, dato che il problema si è presentato dopo aver ritirato lo smartphone dall’assistenza, ti consiglio di portarlo nuovamente a loro prima di eseguire qualche procedura che invalidi la garanzia.

  • Manaf osumanu

    Ciao io ho comprato un clone di iPhone 6s plus e non mi viene più il logo di accensione dell iphone ma mi viene quello della Mediatek come faccio mi auutereste

    • Ciao, devi ottenere i permessi di root e poi utilizzare un’app per cambiare il logo di accensione.

  • Marco Valentino

    Salve Simone, grazie per il post, io ho un mediacom g400 ma la procedura non funziona, sarà perché devo abilitare i permessi di root? Grazie in anticipo per la risposta

  • Viktor

    Ciao una domanda URGENTE quando dici : 6.Alla linea AT+ per la SIM 1, immettere: AT+EGMR=1,7,IL-PRIMO NUMERO IMEI , quindi devo scrivere AT+EGMR=1,7,E IL MIO CODICE IMEI TUTTO QUESTO ATTACCATO SENZA SPAZI? PERCHE; MI DICE IL COMANDO NON E’ PERMESSO IN USERBUILD . COME FACCIO? HO UN MEIZU M2NOTE DUAL SIM.

  • Rocco Vitale

    Ragazzi una domanda. io ho uno z4 clone dual sim.
    Emei perduti dopo formattazione e aggiornamento.
    Ne ho presi due da un samsung vecchio e rotto dual sim.

    inseriti grazie alla vostra procedura tutto funziona eccetto la rete internet.
    sul cell mi compare la scritta G, e zero connessione dati.
    sapreste aiutarmi?

    • Ciao, hai verificato se nelle impostazioni i dati cellulare sono attivi e se sono prese nei tutte le configurazioni del tuo operatore?

  • Francesco Fiorica

    salve ho un telefonino clone s7 edge con processore MT6580 quando vado in engineer mode non mi trova engineer mode mtk ma solo android

  • Fabry

    Ciao Simone.

    Posseggo da 2 anni lo smartphone Zopo Zp980 Plus dual sim -Processore Mediatek Octa-Core MT6592 a 1.7 GHz con
    Android versione 4.2.2 Jelly Bean.
    Dopo un ripristino di fabbrica effettuato con flash tool rimettendo il firmware originale ho provato in tutti i modi anche tramite programmi ma il codice Imei non rimane permanente e dopo qualche riavvio o alcuni minuti scompare.
    Comunque anche quando è visibile è impossibile effettuare telefonate, sms e connessione dati con qualunque sim. Il wi-fi funziona. Non ho copia di partizione Nvram. Il codice Imei anche se originale ho controllato sul sito http://www.numberingplans.com/?page=analysis&sub=imeinr ed ho avuto conferma che è tutto a posto. Vorrei sapere se c’è una soluzione alternativa al mio problema che mi affligge in quanto è un peccato avere un telefono perfettamente funzionante ma non poterlo utilizzare. Grazie

  • Ciao, solitamente il metodo proposto in questa guida risolve il problema permanentemente. Hai provato a flashare nuovamente il firmware e poi correggere nuovamente l’IMEI?

    • Fabry

      Ciao grazie per avermi risposto. Si l’ho fatto tanto di quelle volte che non si contano, così come tanti i modi per rimettere il codice Imei, anzi poco fa ho provato ad inserire quello di un altro mio vecchio telefono che non uso più ma il risultato è sempre lo stesso, che dopo il secondo riavvio il codice Imei non appare più e riporta imei non valido 🙁

      • Sinceramente è un problema molto strano. Non saprei cosa consigliarti se non i metodi che certamente hai già testato. A questo punto, se possibile, cerca di rivolgerti all’assistenza.

    • ALESSANDRO LIAROS

      Ciao simone,sinceramente l ultima possibilità sarebbe il programma che ho visto usare e con successo Z3 TOOL PRO v24.3 per craccare il cell !però tutti i siti che ho visitato per scaricare il programma sono pieni di virus e inoltre non mi fanno scaricare niente…!!!se riesce a farmi sapere come fare o deve andare saresti un grande..!?appena hai tempo attendo notizie.!grazie e buon anno..

      • Ciao, ne ero venuto a conoscenza anche io. Ma penso sia più uno specchietto per le allodole messo lì per guadagnare con la pubblicità. Non si riesce a scaricarlo in nessun modo.

  • Giovanni Barbato

    ciao simone io ho un oukitel c4 faccio l’istallazione del programma ma nella voce engineer mode mi esce solo android come devo fare???
    grazie

    • Ciao, il processore del tuo smartphone non è tra quelli compatibili con questo metodo.

  • Paleari Renato

    Buongiorno Simone io ho acquistato da poco un S7 Edge clone con sistema MT6580. Il telefono ha un problema; non riceve bene il segnale. Il venditore mi ha detto di modificare il codice Imei. Cosa che ho già fatto ma è rimasto il problema, vorrei gentilmente sapere da lei cosa posso fare per risolvere questo problema. In attesa di una sua risposta. Distinti saluti.

    • Ciao Renato, quello da te descritto è un problema molto vasto e difficilmente risolvibile con i pochi dati a disposizione. Quello che consiglierei di fare è inizialmente un ripristino alle impostazioni di fabbrica. Successivamente proverei con diverse SIM di diversi operatori per capire se il problema è il telefono oppure l’operatore. Anche spostandoti in posti diversi della città il problema non cambia?

    • Ciao Renato, quello da te descritto è un problema molto vasto e difficilmente risolvibile con i pochi dati a disposizione. Quello che consiglierei di fare è inizialmente un ripristino alle impostazioni di fabbrica. Successivamente proverei con diverse SIM di diversi operatori per capire se il problema è il telefono oppure l’operatore. Anche spostandoti in posti diversi della città il problema non cambia?

  • Paleari Renato

    Buongiorno Simone io ho acquistato da poco un S7 Edge clone con sistema MT6580. Il telefono ha un problema; non riceve bene il segnale. Il venditore mi ha detto di modificare il codice Imei. Cosa che ho già fatto ma è rimasto il problema, vorrei gentilmente sapere da lei cosa posso fare per risolvere questo problema. In attesa di una sua risposta. Distinti saluti.